Friday, November 9, 2018

MATERI PEMBELAJARAN

ADMINISTRASI SISTEM JARINGAN
Domain name system 
(DNS Server)

Kompetensi Dasar : 


3.7  Mengevaluasi DNS Server
4.7  Mengkonfigurasi DNS Server

INDIKATOR PENCAPAIAN KOMPETENSI :
3.1.7 Menjelaskan konsep DNS Server
3.1.7 Menentukan cara konfigurasi DNS Server
4.1.7 Melakukan konfigurasi DNS Server
4.1.7 Menguji hasil konfigurasi DNS Server

MATERI :

Pengertian DNS

Domain Name System atau yang biasa disingkat dengan DNS adalah sebuah sistem yang berfungsi menterjemahkan alamat IP ke nama domain atau sebaliknya, dari nama domain ke alamat IP. Jadi, host komputer mengirimkan queries berupa nama komputer dan domain name server yang kemudian dipetakan ke dalam alamat IP oleh DNS .

DNS ditemukan pada tahun 1983 oleh Paul Mockapetris, dengan spesifikasi awal RFC 882 dan 883. Empat tahun kemudian pada 1987, spesifikasi DNS dikembangkan menjadi RFC 1034 dan RFC 1035. DNS berguna untuk melakukan komunikasi data di jaringan internet yang sangat luas. Sebelum adanya DNS, dahulu digunakan file HOST.TXT dari SRI pada seluruh komputer yang terhubung dengan jaringan untuk memetakan alamat ke sebuah nama. Namun sistem ini memiliki keterbatasan, karena setiap kali satu alamat komputer berubah, sistem yang berhubungan dengan komputer tersebut harus melakukan update file HOST. Keterbatasan ini kemudian digenapi dengan hadirnya DNS.

coba dengarkan penjelasan DNS berikut :





Cara Kerja DNS




  1. Pada komputer client dengan bantuan browser membuka alamat google.com, nantinya sebuah aplikasi host yang bernama resolver akan mengakses domain system tersebut. Resolver akan menghubungi DNS server, yang disebut name server.
  2. Name server nantinya akan mengecek apakah domain dengan alamat google.com ada di database, bila tidak ditemukan makan akan di redirect ke name server root server.
  3. Bila database ditemukan, client nantinya bisa terhubung ke domain google.com yang direquest client tadi via browser.
lebih jelasnya lihat video cara kerja DNS berikut :


Fungsi DNS

DNS tentunya memiliki fungsi tersendiri dalam jaringan internet. Berikut merupakan beberapa di antaranya :
  1. Melakukan identifikasi alamat komputer dalam suatu jaringan : tiap komputer yang terhubung dengan jaringan internet pasti memiliki alamat IP tersendiri. Dengan adanya DNS, maka jaringan internet kemudian dapat memetakan komputer tersebut sebagai bagian kecil yang terhubung dalam jaringan.
  2. Sebagai penyedia alamat IP bagi tiap host : pada dasarnya, setiap pengembang website membutuhkan sebuah host agar websitenya dapat diakses kalangan umum. Dengan adanya DNS, alamat IP dari tiap host akan dapat teridentifikasi sehingga tiap host akan memiliki alamat IP-nya masing-masing.
  3. Melakukan pendataan server email : Setiap kali server mail bekerja baik untuk menerima atau meneruskan sebuah email, maka data-datanya akan dimonitor oleh DNS.
  4. Mentranskripsikan nama domain menjadi IP address : tiap website di internet memiliki domain tersendiri, seperti .com, .org, .id, dan sebagainya. Melalui browser biasanya yang terlihat adalah alamat sebuah situs dalam bentuk domainnya. DNS dapat menerjemahkan domain menjadi IP Address dan sebaliknya.
  5. Mempermudah user untuk tidak perlu mengingat alamat IP : Jika tidak ada DNS, maka jaringan tidak akan mampu mengakses alamat yang diketikkan pada web browser. Misalnya saja ketika kita ingin mengakses www.google.com, tanpa adanya DNS, komputer tidak dapat menemukan halaman Google karena alamat IP belum teridentifikasi.
ingin lebih jelas, lihat video berikut :


video Tutorial konfigurasi DNS server :



Untuk modul instalasi DNS Server biasa anda downlod di https://dewismkn1kaliwungu.blogspot.com/2013/01/sandal.html 

Untuk  materi WEB SERVER Silahkan buka link berikut : 
https://dewismkn1kaliwungu.blogspot.com/2018/11/web-server.html  



SEMOGA BERMANFAAT

9 comments:

  1. terimakasih materinya , pas dengan yang saya butuhkan. lanjutkan min

    ReplyDelete
    Replies
    1. semoga bermanfaat.. tunggu materi selanjutnya yaa..

      Delete
  2. Maaf kakak mohon bantuannya audionya tidak terdengar untuk penjelasan DNS.

    ReplyDelete
    Replies
    1. coba buka nya pakai pc yang ada speakernya,, :D

      Delete
  3. makasih kak, materinya sangat membantu...

    ReplyDelete
  4. Alhamdulillah,, semoga bermanfaat..

    ReplyDelete
  5. sudah saya coba konfigurasi DNS, tp kenapa di nslookup tidak bisa muncul yaa??

    ReplyDelete
    Replies
    1. Jika saat dilakukan "nslookup IP" maupun "nslookup domain name" hasilnya connection timed out; no servers could be reached, itu dikarenakan kesalahan pada resolv.conf. Buka nano /etc/resolv.conf dan lakukan pengeditan terhadap masalah yang ada. Setelah itu simpan (Ctrl + X). Restart bind9 dengan cara ketik /etc/init.d/bind9 restart. Cek lagi dengan perintah nslookup 192.168.1.29 atau nslookup debian.com

      Delete